MPLS ***第六话:PC-CE间运转OSPF的小深化51CTO博客 - 千亿集团

MPLS ***第六话:PC-CE间运转OSPF的小深化51CTO博客

2019年02月26日15时22分41秒 | 作者: 辰宇 | 标签: 运转,路由,试验 | 浏览: 199

 刚开学的时分在淘宝上买了一本盗版的《MPLS和***体系结构 CCIP版》,现在看着很是头大。倒不是平话映的不可,而是这本书太深邃了,不知道怎样读下去。硬着头皮看了多半,真实不想翻了。翻译有问题,很多当地翻译的很突兀,这却是其次,首要的问题是理论性的东西太多了,可是又泛泛而谈,云里雾里的,看一遍下来都不得要旨。试验印证的部分也太少,学起来真的不知道怎么下手。总归,这本书不引荐。手头有一本咱们试验室的CCIE(SP)苏老板引荐的cisco出的文档,700多页,全英文,其时想把中文的搞定了再来啃他深化学习。这一个多星期看看这个文档后,真是懊悔早没看啊!

下面这段文字是读PE-CE运转OSPF的一点读书笔记,合作一个小试验。

在传统的OSPF主干区域里传输TYPE 3的LSA时,有必要是从area 0区域的街坊传来的才接纳,可是在MPLS ***下CE端无法构成街坊,因而,提出了superbackbone的概念。超级主干区域的引进带来的改动就是一切连接到超级主干的区域,不论其是backbone area 仍是non-backbone area ,都视为backbone area。也就是说,传统的OSPF不再需求主干区域。只要当PE连接了同一个OSPF下的不同area 时,PE才需求运转在主干区域。 在超级主干,不再有adjacent联系或许flooding,只要运转sham-link时才会构成街坊。PE经过MBGP-iBGP来运载拓宽特点。

下图是MPLS ***下的OSPF的拓宽特点

 

*关于route拓宽特点的option字段:假如设置为1表明E2,假如为0表明E1.

*关于domain-id:这个值默许就是取ospf的进程号。咱们能够在OSPF进程下经过domain-id xx来修正。对端的PE假如接纳到的routes的domain-id与自己的不同,就当作type-5来接纳。

*上诉言辞有待试验验证!

Domain-id在MPLS ***中对OSPF是一个十分重要的概念,差异于传统OSPF,MPLS依靠domain-id来进行OSPF的路由传输。默许情况下domain-id就是process number,这个值在OSPF路由充沛不进MP-iBGP的时分设置。

试验:首要对上面论说的一些概念结合实际的试验印证一下。

拓扑:

描绘:

1.              CE1-A和CE2-A作为*** A的两个长途客户端接入路由器,别离发布内部网络172.16.10.0/24和172.16.20.0/24进入OSPF。

2.              PE-CE间运转的OSPF的process id号码为100,这个值在试验中要点重视。此外,PE-CE都运转在AREA 0。

3.              P网络内部运转ISIS树立MPLS,PE1-AS1和PE2-AS1间运用loopback 0树立MP-iBGP。

装备:

CE1-A

CE1-A#sh run

(….omitted)

hostname CE1-A

!

memory-size iomem 5

ip cef

!

interface Loopback0

 ip address 172.16.10.1 255.255.255.0

 ip ospf network point-to-point

!

interface FastEthernet0/0

 no ip address

 duplex auto

 speed auto

!

interface FastEthernet0/0.12

 encapsulation dot1Q 12

 ip address 12.1.1.1 255.255.255.0

!

router ospf 100

 router-id 1.1.1.1

 log-adjacency-changes

 passive-interface Loopback0

 network 12.1.1.1 0.0.0.0 area 0

 network 172.16.10.0 0.0.0.255 area 0

!       

PE1-AS1:

E1-AS1#sh run

(….omitted)

hostname PE1-AS1

!

ip cef

!

ip vrf A

 rd 1:0

 route-target export 1:0

 route-target import 1:0

!        

mpls label range 299 2999

mpls label protocol ldp

!

interface Loopback0

 ip address 2.2.2.2 255.255.255.255

 isis circuit-type level-2-only

!

interface FastEthernet0/0

 no ip address

 duplex auto

 speed auto

!

interface FastEthernet0/0.12

 encapsulation dot1Q 12

 ip vrf forwarding A

 ip address 12.1.1.2 255.255.255.0

!

interface FastEthernet0/0.23

 encapsulation dot1Q 23

 ip address 23.1.1.2 255.255.255.0

 ip router isis

 mpls ldp discovery transport-address interface

 mpls ip

 isis circuit-type level-2-only

!

router ospf 100 vrf A

 router-id 2.2.2.2

 log-adjacency-changes

 redistribute bgp 1 subnets

 network 12.1.1.2 0.0.0.0 area 0

!

router isis

 net 47.2340.0000.0000.2222.00

 is-type level-2-only

 metric-style wide

 passive-interface Loopback0

!

router bgp 1

 bgp router-id 2.2.2.2

 no bgp default ipv4-unicast

 bgp log-neighbor-changes

 neighbor 4.4.4.4 remote-as 1

 neighbor 4.4.4.4 update-source Loopback0

 !

 address-family ***v4

 neighbor 4.4.4.4 activate

 neighbor 4.4.4.4 send-community extended

 exit-address-family

 !

 address-family ipv4 vrf A

 redistribute ospf 100 vrf A

 no synchronization

 exit-address-family

!

mpls ldp router-id Loopback0 force

P:

P#sh run

(….omitted)

hostname P

!

ip cef

!

mpls label range 300 399

mpls label protocol ldp

!        

interface Loopback0

 ip address 3.3.3.3 255.255.255.255

 isis circuit-type level-2-only

!

interface FastEthernet0/0

 no ip address

 duplex auto

 speed auto

!

interface FastEthernet0/0.23

 encapsulation dot1Q 23

 ip address 23.1.1.3 255.255.255.0

 ip router isis

 mpls ldp discovery transport-address interface

 mpls ip

 isis circuit-type level-2-only

!

interface FastEthernet0/0.34

 encapsulation dot1Q 34

 ip address 34.1.1.3 255.255.255.0

 ip router isis

 mpls ldp discovery transport-address interface

 mpls ip

 isis circuit-type level-2-only

!

router isis

 net 47.2340.0000.0000.3333.00

 is-type level-2-only

 metric-style wide

 passive-interface Loopback0

!

mpls ldp router-id Loopback0 force

!

*R4,R5装备与R1,R2略同,略。

测验:

1.       PE1-AS1上的MPLS ***的路由表

PE1-AS1#sh ip b *** all

BGP table version is 9, local router ID is 2.2.2.2

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

Route Distinguisher: 1:0 (default for vrf A)

*> 12.1.1.0/24      0.0.0.0                  0         32768 ?

*>i45.1.1.0/24      4.4.4.4                  0    100      0 ?

*> 172.16.10.0/24   12.1.1.1                11         32768 ?

*>i172.16.20.0/24   4.4.4.4                 11    100      0 ?

         如上所示,都正常学到了。

2.       客户端路由

CE1-A#sh ip rou os

     172.16.0.0/24 is subnetted, 2 subnets

O IA    172.16.20.0 [110/21] via 12.1.1.2, 00:30:18, FastEthernet0/0.12

     45.0.0.0/24 is subnetted, 1 subnets

O IA    45.1.1.0 [110/11] via 12.1.1.2, 00:30:18, FastEthernet0/0.12

如上所示,这儿接纳到的路由都是O IA。

 

3.       网络连通性测验

CE1-A#ping 172.16.20.1 sou l0

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.20.1, timeout is 2 seconds:

Packet sent with a source address of 172.16.10.1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 68/87/104 ms

好,也通了。 

下面要点重视在前文中描绘的OSPF route ,domain-id和router-id这三个拓宽特点。其实这三个特点在一条指令中都显示出来了。

PE1-AS1#sh ip b *** all 172.16.20.0

BGP routing table entry for 1:0:172.16.20.0/24, version 9

Paths: (1 available, best #1, table A)

  Not advertised to any peer

  Local

    4.4.4.4 (metric 20) from 4.4.4.4 (4.4.4.4)

      Origin incomplete, metric 11, localpref 100, valid, internal, best

      Extended Community: RT:1:0 OSPF DOMAIN ID:0x0005:0x000000640200

        OSPF RT:0.0.0.0:2:0 OSPF ROUTER ID:4.4.4.4:0

      mpls labels in/out nolabel/403

OSPF DOMAIN ID:0x0005:0x000000640200

         从上面的这个字段能够读出domain-id,这儿的输出与字段格局有点不一样,64是16进制的,转化过来就是100,也就是咱们前面设置的OSPF 进程号,由于默许这个进程号就是作为domain-id写入***v4的。 

OSPF RT:0.0.0.0:2:0

           这儿的0.0.0.0表明OSPF运转在区域0,2表明LSA是类型2(试验中的设备是用FastEthernet端口开子接口完成互联的),最终的0是option字段,假如是类型3的LSA话就显示出含义来了,后边的试验会有讨论。

OSPF ROUTER ID:4.4.4.4:0

           需求这儿,这儿的router-id就是PE的router-id,跟这个网段源自的那个路由器没有联系。

           前文有过告知,domain-id是决议LSA以何种类型的LSA转发的一个关键因素,也就是说,假如是TYPE1 和TYPE2的LSA,假如domain-id一向的话,都是以TYPE3的LSA传递,对端收到的就是O IA路由;假如domain-id不一致的话,就都是以外部路由转发,也就是TYPE 5或许TYPE 7。

           下面修正R4的domain-id,然后调查比照作用。

PE2-AS1(config)#router os 100

PE2-AS1(config-router)#domain-id 0.0.0.200

PE2-AS1(config-router)#end

PE1-AS1#cle ip b * *** un so i

PE1-AS1#sh ip b *** all 172.16.20.0

BGP routing table entry for 1:0:172.16.20.0/24, version 19

Paths: (1 available, best #1, table A)

Flag: 0xA00

  Not advertised to any peer

  Local

    4.4.4.4 (metric 20) from 4.4.4.4 (4.4.4.4)

      Origin incomplete, metric 11, localpref 100, valid, internal, best

      Extended Community: RT:1:0 OSPF DOMAIN ID:0x0005:0x000000C80200

        OSPF RT:0.0.0.0:2:0 OSPF ROUTER ID:4.4.4.4:0

      mpls labels in/out nolabel/403

如上所示domain-id字段改动了,假如你手动算一下就会发现,C8转化成10进制就是200,就是咱们在上面修正后的domain-id。

然后再去CE1-A上看看路由。

CE1-A#sh ip rou os

     172.16.0.0/24 is subnetted, 2 subnets

O E2    172.16.20.0 [110/11] via 12.1.1.2, 00:06:37, FastEthernet0/0.12

     45.0.0.0/24 is subnetted, 1 subnets

O E2    45.1.1.0 [110/1] via 12.1.1.2, 00:06:37, FastEthernet0/0.12

哈哈,都变成OE2路由了。这是默许的路由类型。

 

           

版权声明
本文来源于网络,版权归原作者所有,其内容与观点不代表千亿集团立场。转载文章仅为传播更有价值的信息,如采编人员采编有误或者版权原因,请与我们联系,我们核实后立即修改或删除。

猜您喜欢的文章