动态路由RIP的装备51CTO博客 - 千亿集团

动态路由RIP的装备51CTO博客

2019年02月26日10时00分41秒 | 作者: 碧萱 | 标签: 路由,装备,信息 | 浏览: 1992

RIP试验装备

 

 

一、根本信息装备(略)

二、接口IP装备(如图标明IP

RT1(config)#int e3/0        e3/0IP装备)

RT1(config-if)#ip add 192.168.20.1 255.255.255.0

RT1(config-if)#no shut     (激活接口)

RT1(config-if)#no keepalive (将接口置为不保活,即不管有没有保活信息该接口都能够出于“活”的状况)

RT1(config)#int e3/1        e3/1IP装备)

RT1(config-if)#ip add 192.168.21.1 255.255.255.0

RT1(config-if)#no shut

RT1(config-if)#no keepalive

RT1(config)#int f2/0         f2/0IP装备)

RT1(config-if)#ip add 192.168.2.9 255.255.255.248

RT1(config-if)#no shut

RT1(config)#int s0/2         s0/2的装备)

RT1(config-if)#encapsulation hdlc   S口需求封装一种广域网协议,此处均封装hdlc

RT1(config-if)#clock rate 1000000  (设置时钟频率,只设置链路的一段即可)

RT1(config-if)#ip add 192.168.1.9 255.255.255.252(装备IP

RT1(config-if)#no shut

RT1(config)#int s0/0         s0/0的装备)

RT1(config-if)#en hd

RT1(config-if)#en hdlc

RT1(config-if)#clock r 1000000

RT1(config-if)#ip add 192.168.1.1 255.255.255.252

RT1(config-if)#no shut

RT1(config)#int s0/1         s0/1的装备)

RT1(config-if)#en hd

RT1(config-if)#en hdlc

RT1(config-if)#ip add 192.168.1.5 255.255.255.252

RT1(config-if)#no shu

 

RT3RT5RT7IP装备就不多写了,很简单,依照图示装备即可,S口留意封装hdlc协议,假如对端装备了时钟频率那另一端就不必再装备时钟频率了。

 

三、RIP信息装备

RT1(config)#router rip (敞开RIP

RT1(config-router)#version 2(设置为版别2,版别2是无类路由,传达路由时会带着接口掩码,版别1根本不再用了)

RT1(config-router)#no auto-summary(封闭RIP的主动汇总功用)

RT1(config-router)#network 192.168.20.0  (布告发布的网段,下几句指令也是这样)

RT1(config-router)#network 192.168.21.0

RT1(config-router)#network 192.168.1.0

RT1(config-router)#network 192.168.1.4

RT1(config-router)#network 192.168.1.8

RT1(config-router)#passive-interface default(将RT1的一切接口置为被迫接口,置为被迫接口后就不会从这个接口向外传达RIP路由信息了)

RT1(config-router)#no passive-interface s0/0(将需求传达路由的接口设置为“no”被迫,即,能够从这个接口宣布路由信息,下面几句指令相似)

RT1(config-router)#no passive-interface s0/1

RT1(config-router)#no passive-interface s0/2

 

 

RT3(config)#router rip

RT3(config-router)#version 2

RT3(config-router)#no auto-summary

RT3(config-router)#net 192.168.36.0

RT3(config-router)#net 192.168.37.0

RT3(config-router)#net 192.168.1.0

RT3(config-router)#net 192.168.1.4

RT3(config-router)#passive-interface default

RT3(config-router)#no passive-interface s0/0

RT3(config-router)#no passive-interface s0/1

 

 

RT5(config)#router rip

RT5(config-router)#version 2

RT5(config-router)#no auto-summary

RT5(config-router)#net 192.168.1.8

RT5(config-router)#net 192.168.44.8

RT5(config-router)#passive-interface default

RT5(config-router)#no passive-interface s0/0

 

 

四、其他路由装备(使RIP能够与没有运转RIP的那部分连通)

RT7(config)#ip route 192.168.0.0 255.255.0.0 192.168.2.9  RT7上装备通往RIP区域的静态路由)

 

RT1(config)#ip route 0.0.0.0 0.0.0.0  192.168.2.10   (在RT1上装备缺省路由通往外部区域)

RT1(config)#router rip     (进入RIP装备子模式)

RT1(config-router)#default-information originate           (对RIP区域下发下发缺省路由)

 

五、在设备上检查各自的路由表

RT1 show  ip  route

 

R    192.168.44.0/24 [120/1] via 192.168.1.10, 00:00:18, Serial0/2

C    192.168.21.0/24 is directly connected, Ethernet3/1

C    192.168.20.0/24 is directly connected, Ethernet3/0

R    192.168.36.0/24 [120/1] via 192.168.1.6, 00:00:14, Serial0/1

                     [120/1] via 192.168.1.2, 00:00:09, Serial0/0

R    192.168.37.0/24 [120/1] via 192.168.1.6, 00:00:14, Serial0/1

                     [120/1] via 192.168.1.2, 00:00:09, Serial0/0

     192.168.1.0/30 is subnetted, 3 subnets

C       192.168.1.8 is directly connected, Serial0/2

C       192.168.1.0 is directly connected, Serial0/0

C       192.168.1.4 is directly connected, Serial0/1

     192.168.2.0/29 is subnetted, 1 subnets

C       192.168.2.8 is directly connected, FastEthernet2/0

S*   0.0.0.0/0 [1/0] via 192.168.2.10

 

R代表RIP学到的路由,C代表直连路由,S*代表静态且为缺省的路由。

 

 

RT3show  ip  route

R    192.168.44.0/24 [120/2] via 192.168.1.5, 00:00:08, Serial0/1

                     [120/2] via 192.168.1.1, 00:00:14, Serial0/0

R    192.168.21.0/24 [120/1] via 192.168.1.5, 00:00:08, Serial0/1

                     [120/1] via 192.168.1.1, 00:00:14, Serial0/0

R    192.168.20.0/24 [120/1] via 192.168.1.5, 00:00:08, Serial0/1

                     [120/1] via 192.168.1.1, 00:00:14, Serial0/0

C    192.168.36.0/24 is directly connected, Ethernet3/0

C    192.168.37.0/24 is directly connected, Ethernet3/1

     192.168.1.0/30 is subnetted, 3 subnets

R       192.168.1.8 [120/1] via 192.168.1.5, 00:00:08, Serial0/1

                    [120/1] via 192.168.1.1, 00:00:14, Serial0/0

C       192.168.1.0 is directly connected, Serial0/0

C       192.168.1.4 is directly connected, Serial0/1

R*   0.0.0.0/0 [120/1] via 192.168.1.5, 00:00:08, Serial0/1

               [120/1] via 192.168.1.1, 00:00:14, Serial0/0

R*代表RIP下发缺省路由得到的路由条目,这条路由指向的当地就是下发缺省路由的设备。

 

RT5show  ip  route

C    192.168.44.0/24 is directly connected, Ethernet3/0

R    192.168.21.0/24 [120/1] via 192.168.1.9, 00:00:21, Serial0/0

R    192.168.20.0/24 [120/1] via 192.168.1.9, 00:00:21, Serial0/0

R    192.168.36.0/24 [120/2] via 192.168.1.9, 00:00:21, Serial0/0

R    192.168.37.0/24 [120/2] via 192.168.1.9, 00:00:21, Serial0/0

     192.168.1.0/30 is subnetted, 3 subnets

C       192.168.1.8 is directly connected, Serial0/0

R       192.168.1.0 [120/1] via 192.168.1.9, 00:00:21, Serial0/0

R       192.168.1.4 [120/1] via 192.168.1.9, 00:00:21, Serial0/0

R*   0.0.0.0/0 [120/1] via 192.168.1.9, 00:00:21, Serial0/0

 

RT7show  ip  route

     202.202.202.0/29 is subnetted, 1 subnets

C       202.202.202.200 is directly connected, FastEthernet1/0

     192.168.2.0/29 is subnetted, 1 subnets

C       192.168.2.8 is directly connected, FastEthernet2/0

S    192.168.0.0/16 [1/0] via 192.168.2.9

 

 

六、试验总结

1、  关于RIP的被迫接口

被迫接口一般装备在那些不需求传达RIP路由信息的接口上,比方直接接PC的那些端口,而需求将路由信息传达出去的接口是不要装备被迫接口的,工程化标准中,但凡不需求传达路有音讯的那些接口都要装备为被迫接口,所以用一条passive-interface default指令来使一切的接口成为被迫接口,然后“no”掉那些需求传达路由的接口即可。总归,除了要传达路由信息的接口,其他的都要装备成被迫接口。

2、  下发缺省路由

default-information originate这条指令就是用来下发缺省路由的,下发路由的设备会通知其他路由器:“你们假如有不识其他路由,通通发给我!”,而当收到他们传来的路由时,假如自己也不知道,那么就查找自己的路由表,依照自己的缺省路由进行转发。

3、  关于版别

这儿咱们都用RIP v2的版别,而且封闭主动汇总。因为版别1只能发送有类路由信息,路由条目十分的不精确,所以版别2进行了改善,版别2使用的无类路由,会带着掩码信息,可是在这儿也有必要封闭它的主动汇总功用,不要让协议自己去帮你汇总,不然会使路由条目逃出你的掌控规模。

(其他要留意的东东暂时没想到,嘿嘿)

 

版权声明
本文来源于网络,版权归原作者所有,其内容与观点不代表千亿集团立场。转载文章仅为传播更有价值的信息,如采编人员采编有误或者版权原因,请与我们联系,我们核实后立即修改或删除。

猜您喜欢的文章